Port Forwarding Mikrotik Using DMZ or PPPoE

if dial-in modem (you must download the DMZ interface Mikrotik)
use in-physical interface leading to the modem

modem = 192.168.1.1 (DMZ to 192.168.1.2)
ether1(modem) = 192.168.1.2
local webserver = 10.0.0.1/24

example DMZ

#port forwarding to local ssh
/ip firewall nat add chain=dstnat in-interface=ether1 dst-address=192.168.1.2 protocol=tcp dst-port=22 action=dst-nat to-address=10.0.0.1 to-port=22


if mikrotik dial
use a virtual interface that is formed from pppoe-client dial

example dial PPPoE
after you dial in your proxy using the name = pppoe-alva and you get Public IP = 0.0.0.0

/interface pppoe-client add name=pppoe-alva interface=ether1 add-default-route=yes use-peer-dns=yes dial-on-demand=no user=0.0.0.0@yourisp.net password=xxxxxxx
#port forwarding to local ssh
/ip firewall nat add chain=dstnat in-interface=pppoe-alva dst-address=0.0.0.0 protocol=tcp dst-port=22 action=dst-nat to-address=10.0.0.1 to-port=22